[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

How to use mozjs from xulrunner?



Hi,

I attempted to optimise the gxine package, which uses JS library, for
xulrunner, as I though it might be better to use xulrunner's mozjs,
rather than libjs as xulrunner is already needed for it's mozplugin, so
I have locally built a copy with xulrunner's mozjs used and I got this
error when I try to run the application: 

gxine: error while loading shared libraries: libmozjs.so: cannot open
shared object file: No such file or directory. 

So I reverted back to libjs until it is fixed.

I also tried latest hg snapshot, which dropped support for libjs
altogether, with the same result.

One thing that fixes the issue is making a symlink in /usr/lib
to /usr/lib/xurunner-$version$/mozjs.so

What could be wrong? I also noticed that there are problems with mozjs
header files where the xulrunner-js.pc file directs to 'stable' subdir
of xulrunner includes, while the mozjs is in 'js' subdir.

I have xulrunner-devel-1.9-0.alpha9.2.fc9 installed in my otherwise F8
box.

Thanks,
Martin


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]