[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Font issues (mkfontdir & friends not getting run) with F-8



Hi,

On both my F-8 x86_64 live-dvd installation and my (clean) F-8 i386 install dvd installation, not all scriptlets for font-packages have properly run.

Taking /etc/X11/fontpath.d/fonts-default (urw-fonts) as example:
-On the x86_64 live dvd install, only fonts.scale is present, iow
 mkfontdir and fc-cache have not been run, even though they are in the
 scripts:
[hans localhost ~]$ rpm -q --scripts urw-fonts
urw-fonts-2.4-1.fc8.noarch
postinstall scriptlet (using /bin/sh):
{
   umask 133
   mkfontscale /usr/share/fonts/default/Type1 || :
   `which mkfontdir` /usr/share/fonts/default/Type1 || :
   fc-cache /usr/share/fonts
} &> /dev/null || :

-On the i386 dvd install, nothing was run, so not only mkfontdir and
 fc-cache were not run, but also mkfontscale has not been run

The strange thing is fontconfig is actually required, so atleast the fc-cache file should have been created.

As for the other two not being created, well that is to be expected if the necessary packages are not added to any Requires.

Why are these files generated on install anyways, I understand this used to be usefull back in the days when multiple packages would install files under one dir, but isn't it so that most font dirs now only contain fonts from one package?

Note that this is not isolated to urw-fonts, ghostscript-fonts for example has the same problem.

Regards,

Hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]