[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken dependencies: xfce4-sensors-plugin



Am Dienstag, den 20.11.2007, 02:54 -0700 schrieb
buildsys fedoraproject org:
> 
> xfce4-sensors-plugin has broken dependencies in the development tree:
> On ppc:
> 	xfce4-sensors-plugin - 0.10.99.2-1.fc9.ppc requires libsensors.so.3
> On x86_64:
> 	xfce4-sensors-plugin - 0.10.99.2-1.fc9.x86_64 requires libsensors.so.3()(64bit)
> On i386:
> 	xfce4-sensors-plugin - 0.10.99.2-1.fc9.i386 requires libsensors.so.3
> On ppc64:
> 	xfce4-sensors-plugin - 0.10.99.2-1.fc9.ppc64 requires libsensors.so.3()(64bit)
> Please resolve this as soon as possible.

This is because development has switched to lm_sensors 3.0.0 RC1. I
tried to rebuild the package but it won't build with the new lm_sensors
API. I informed upstream about it and they told me

> I guess, I'll ignore their changes for a few months. API breaking in
> libs is always ugly (although it is a very ugly API). And I am not
> willing to introduce #ifdefs for them.

What am I supposed to do in a case like this? Can we temporarily remove
the package from the development repo?

Christoph



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]