[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Firefox sets wrong encoding to directory listings?



Hi,

not sure if this is the right list, but I set up a http server for some
local network (so it is not accessible from outside) and would like to
have all the content in UTF-8 (I also use some non ISO-8859-1 characters
in file names), so I set up a HEADER.xhtml that is prepended to
directory listings (and the same file is included at the beginning of
the other pages) with this encoding settings:

<?xml version="1.0" encoding="UTF-8"?>
...
<meta http-equiv="content-type" content="text/html; charset=UTF-8"/>
<meta http-equiv="content-type" content="application/xhtml+xml;
charset=UTF-8"/>

So, I would suppose that browser detects the character encoding right
and selects UTF-8. However, while this is true for ordinal pages, for
directory listings it always selects ISO-8859-1. I also went through the
apache configuration files and tried both using AddDefaultCharset UTF-8
and not using it with the same result.

As you might noticed, I thought at first that this is a server issue,
but I just tried it in ELinks and it works as expected. So, where the
problem lies? I have problems with it when using epiphany or firefox.
Should I file a bug against firefox?

Thanks,
Martin

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]