[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/postfix/devel postfix.spec,1.60,1.61



On Wed, 28 Nov 2007 10:19:13 -0800
devrim CommandPrompt com (Devrim GÜNDÜZ) wrote:

> Hi,
> 
> On Wed, 2007-11-28 at 11:04 -0700, Kevin Fenzi wrote:
> > Upstream doesn't support loading them on the fly, so if it's
> > enabled it means installing postfix pulls in mysql and posgresql. :(
> 
> Ok, so why don't we do it the Debian way: Compile postfix with both
> PostgreSQL and MySQL support, and then provice dict_pgsql.so with
> postfix-pgsql rpm (or same for -mysql package):
> 
> # dpkg -L postfix-pgsql
> /.
> /usr
> /usr/lib
> /usr/lib/postfix
> /usr/lib/postfix/dict_pgsql.so
> /usr/share
> /usr/share/doc
> /usr/share/doc/postfix-pgsql
> /usr/share/doc/postfix-pgsql/README.Debian
> /usr/share/doc/postfix-pgsql/copyright
> /usr/share/doc/postfix-pgsql/changelog.Debian.gz

Unfortunately, debian uses a local patch to provide dynamic loading of
postgresql support, which according to our postfix maintainer is buggy
and also doesn't work on all the platforms fedora supports. ;( 

See the merge review ticket for more info: 
https://bugzilla.redhat.com/show_bug.cgi?id=226307

> Regards,

kevin

Attachment: signature.asc
Description: PGP signature


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]