[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: alpha/beta software in Fedora 8?



Steve Grubb <sgrubb <at> redhat.com> writes:
> How about unreleased cvs snapshots? kdepim in F7 failed to work after a
> recent upgrade (and had been working fine) and my problem was only solved by
> upgrading to F8 which had a more recent cvs snapshot that is still buggy but

I'll sched some light on the situation of kdepim:

Basically, the problem is that the last really stable release of kdepim, 
especially KMail, was 3.5.6. When we upgraded KDE to 3.5.7, we were hit by 2 
serious regressions in KMail IMAP filtering, which made IMAP filters 
essentially unusable (one of them broke automatic filtering and one manual 
filtering). The bugs were reported upstream, but nobody knew how to fix 
automatic filtering in 3.5.7. This situation persisted for weeks. At that point 
other distributions (at least openSUSE and Kubuntu, probably more) started 
shipping kdepim from the enterprise branch, so we tried that, and found in our 
testing that it fixed the KMail IMAP regressions. However, nobody upstream knew 
how to backport whatever made it work in the enterprise branch to the regular 
3.5 branch, nor did we. So, given how many complaints we got about those IMAP 
regressions (complaints of the "you broke my KMail" type, which weren't 
unreasonable given what happened), we decided to rush the enterprise branch 
update as an F7 update so this gets finally fixed, as no other fix was in 
sight. (We considered reverting kdepim to 3.5.6, but there were other changes 
in 3.5.7 we didn't want to revert, e.g. in KitchenSync.) A few people tried the 
kdepim enterprise build before we pushed it to F7 stable updates, none of them 
reported any problems, the only reports we got about it was that it fixed the 
IMAP regressions.

The current situation is now that:
* the newer snapshot which fixes your problems will be pushed to Fedora 7 
updates (or already was? Which snapshot fixed your problems? F7 currently has 
20071013, an update to a 20071129 snapshot is being prepared) and
* the enterprise branch is planned to be merged into the regular KDE 3.5 kdepim 
branch before KDE 3.5.9, in other words, KDE 3.5.9 will ship with 
kdepim-enterprise.

> usable. Rolling back did not work. The only support I got by the Fedora 
> maintainer was telling me to report it upstream. Upstream does not support it 
> because its a cvs snapshot and not a released version.

Upstream really should support it because 1. it's scheduled to be merged into 
the next release and 2. it's being shipped by several distros.

> What do we do about that?

We wait for KDE 3.5.9, where this problem should just go away. For now, we'll 
keep pushing newer snapshots if they're needed to fix bugs.

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]