[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: samba license change



Simo Sorce wrote:
On Tue, 2007-10-09 at 11:56 +0530, Rahul Sundaram wrote:
Essentially unless the entire dependency chain for Samba is GPLv3 compatible, a new samba version under GPLv3 or later would be impossible to pull as incompatible licensing is a liability for the distribution and not necessarily for the individual components.

It's the other way around, it is KDE (Konqueror uses libsmbclient) that
depends on Samba, Samba has no dependency problems at all.

Right but then Fedora would end up with a license violation if you push the GPLv3 samba into the distribution. Whatever packages depends on samba needs to be GPLv3 compatible before we do the push.

Rahul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]