[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: samba license change



Andrew Bartlett wrote:


The problem is, there is no long-term will to maintain such a -compat
package.  How long would such a package last - forever if other packages
don't move?  Who would maintain it?

I assume whoever is dependent on Samba but can't make the move to a compatible license would be interesting in maintaining it. I don't think it is feasible for us to have a new release of Fedora where something as major as GNOME or KDE does not have any Samba support. Do you?

The bit that bothers me is that not only was Samba for the longest time
mentioned in most GPLv3 news articles, we asked if anybody had a reason
not to change our licence, and nobody gave a compelling reason.

Things are not working a vacuum. You know the major players in Free dependent on Samba which includes GNOME and KDE. The license incompatibility that would occur as a result of this move was very plain to everyone involved. Such a transition can take several months if we have to introduce it into the distribution. I don't see any way out of a maintaining a GPLv2 version of Samba for a while unless everyone involved moves to GPLv3 or compatible licenses for their own software quickly if they are dependent on Samba.

Rahul


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]