[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: samba license change



Kevin Kofler wrote:
Andrew Bartlett <abartlet <at> samba.org> writes:
The bit that bothers me is that not only was Samba for the longest time
mentioned in most GPLv3 news articles, we asked if anybody had a reason
not to change our licence, and nobody gave a compelling reason.

There definitely have been complaints from the KDE camp, both on public news sites like Slashdot and on KDE developer blogs.

See, the KDE project can't just move to GPLv3, most of their code is actually LGPL (which allows converting to any GPLv2+) or GPLv2+ already, but Qt is GPLv2 only. So KDE can't do anything without Trolltech, and Trolltech is still in the "evaluating their options" phase.

Also be aware that if the problem gets solved, it will be solved only for KDE 4, KDE 3 relies on Qt 3 which is not supported by Trolltech anymore, so the chances for that to change its license are essentially nil.


I must say I'm sorry to step into this flamefest, but weren't the QT licensing issues the reasons why we have gnome in the first place? So all in all it turns out that despite all trolltech's promises, they don't follow through?

Its really simple to me, TrollTech has the power to fix this, and they should, so instead of endless discussions here, maybe those that care should focus their efforts on TrollTech instead?

Regards,

hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]