[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: FC-6: automake-1.9 on ppc



Le Tuesday 09 October 2007 18:10:53 Stepan Kasal, vous avez écrit :
> Hello,
>
> On Mon, Oct 08, 2007 at 09:56:38AM +0200, Alain PORTAL wrote:
> > Previously, I "BuildRequires: automake", but it seems I made a mistake
> > and I removed it...
>
> but you should understand that this would break if automake were
> upgraded to 1.10.

I don't think.
I think if automake is upgraded, it will be search for the upgrade.

> I do not think this is a real possibility in FC-6, 
> so your solution is adequate here.
>
> But for general development, let me remind that there are only two
> safe options:
>
> 1) either you rely on the autotools-generated files packed in the
> tarball, in which case you do not need to BuildRequire anything.

It seems I can't rely on these files because when I run ./configure && make, 
make rerun ./configure

> 2) Or you do refresh the autotools generated stuff fully, so you need
> at least:
>
> BuildRequire: autoconf automake
> %build
> aclocal
> autoconf
> automake
>
> The aclocal collects various *.m4 files so you often need
> 	aclocal -I m4
> for *.m4 files in the m4/ subdir of the tarball, and you often need
> to BuildRequire libfoo-devel, if libfoo is used by your package and
> if it contains a /usr/share/aclocal/foo.m4
>
>
> As you see, the second option can get a bit complicated, so if the
> only problem is a time stamp mistake in the upstream tarball, it
> might be a better idea to make the upstream to realease a fixed
> tarball, or find the bug and patch it by a "touch -r".

I'm not sure this is a time stamp problem. Project is manage with Kdevelop and 
this is Kdevelop which generate the files.
The real problem is that I'm the new upstream and I don't know how to fix...

Regards,
Alain
-- 
La version française des pages de manuel Linux
http://manpagesfr.free.fr


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]