[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: samba license change



On Wed, 2007-10-10 at 16:38 +0000, Kevin Kofler wrote:
> Simo Sorce <ssorce <at> redhat.com> writes:
> > Slashdot ? On Slashdot anybody can say anything and the contrary, I
> > wonder why people is so shy to talk directly with other developers when
> > they need to...
> 
> There were also some developer blogs. There may have been some lack of 
> communication. But do you expect them to follow every single thread on your 
> mailing list? You don't follow every single thread on kde-core-devel, or even 
> every single thread related to licensing there, either, do you?

No but we were on the headlines both during the GPLv3 process and when
we announced the license change so we made our part to get visible and
inform others. I follow each announcement of license change for the code
we depend on  and make sure we have no problem for it, if we have we
contact the devs of the other project promptly and discuss the
situation.

> > If Qt3 is obsolete I can't understand why Trolltech can't add an
> > exception there, it should be actually much more easier for older
> > unsupported software, after all who cares for that? It's going to slowly
> > disappear from the scene anyway and GPLv2 vs GPLv2+/exception for v3
> > does not make any difference in that case.
> 
> Historically, Trolltech has always done license changes only for the new 
> versions, I think they want to use that as leverage to force people to use the 
> new version, which is annoying in the context of KDE where KDE is generally not 
> ready for said new version yet when they do the change.

I undertand that but I guess Trolltech can be asked at least to say a
word or two, so far I know only Trolltech is 'thinking' about it. Can
someone that know them please get in touch with Trolltech and get us
some facts to discuss on? Speculation is annoying.

> As for GPLv2+exception: is the affected Samba code GPLv3+ or LGPLv3+? If it's 
> LGPLv3+, an exception in Qt might work (but we'd still need Trolltech to grant 
> it!), if it's GPLv3+, we need an exception from BOTH sides.

I don't understand this. It is GPLv2 only that is incompatible, once
Trolltech makes it v2+ or dual license it under v3/v3+ we have no
problems.

> > In any case I was under the impression that F9 was going to use
> > KDE4/QT4, have plans changed ?
> 
> That's the plan. But this mess will essentially force us to move (leaving us 
> with no fallback plan), and that's only if Trolltech updates the Qt 4 license, 
> if they don't, we're stuck. Well, we can ship a KDE without SMB support, but is 
> that really what you want in the Samba project?

We don't like the situation but what is our option? We strongly believe
the GPLv3 is the right license for Samba.

> Don't get me wrong, I agree Trolltech's use of GPL v2 only and not doing 
> anything about the GPLv3 (at least not fast enough) is bad, but Samba 
> essentially knowingly sabotaging what's probably their biggest user isn't a 
> solution to that problem either.

Sorry, our biggest users are Windows clients and linux clients via
smbfs/cifs kernel modules.
KDE is only one of the many clients like GNOME on one of the platforms.
Nonetheless we are concerned about that and that's why we are sending
signals to people in *advance*.
But you don't expect us to do the work for these projects, do you?

Simo.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]