[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

koji server installation



Hello Mike,

I'm installing a local Koji server at OLPC so we could create as
topical integration streams such as "rainbow", "xtest", "sugar"...

I installed all the koji packages following the tutorial on the
fedoraproject wiki.  The web interface is up and running:

  http://bender.codewiz.org/koji/

I configured it similar to the koji.fedoraproject.org setup, but
I can't seem to get builds to work.

First of all, I get these errors:

2007-10-18 09:12:56,389 [WARNING] koji.build.TaskManager: FAULT:
Traceback (most recent call last):
  File "/usr/sbin/kojid", line 1109, in runTask
    response = (handler.run(),)
  File "/usr/sbin/kojid", line 1185, in run
    return self.handler(*self.params,**self.opts)
  File "/usr/sbin/kojid", line 2174, in handler
    repo_id, event_id = self.wait(preptask)[preptask]
  File "/usr/sbin/kojid", line 1272, in wait
    return dict(session.host.taskWaitResults(self.id,subtasks))
  File "/usr/lib/python2.5/site-packages/koji/__init__.py", line 1077, in __call__
    return self.__func(self.__name,args,opts)
  File "/usr/lib/python2.5/site-packages/koji/__init__.py", line 1304, in _callMethod
    raise convertFault(fault)
Fault: <Fault 1: "<type 'exceptions.OSError'>: [Errno 13] Permission denied: '/mnt/koji'">

...even though I had set topdir=/usr/local/koji in /etc/kojid/kojid.conf.

The problem seems to be that PathInfo gets instantiated with no topdir and
so it gets the default from BASEDIR, but even after fixing that I still got
sporadic errors elsewhere until I replaced all instances of "/mnt/koji"
everywhere.

I'd suggest taking off these defaults and hard-failing when the client code
did not provide a default.  It's still better than using the configured path
only half of the times.

After fixing this problem, I got a different one:

bender:/home/bernie/src# koji --debug build dist-olpc2 xorg-x11-proto-devel-7.2-13.olpc2.src.rpm
successfully connected to hub
Uploading srpm: xorg-x11-proto-devel-7.2-13.olpc2.src.rpm
[====================================] 100% 00:00:07   1.30 MiB 171.37 KiB/sec
Created task: 3748
Task info: http://bender.codewiz.org/koji/taskinfo?taskID=3748
Watching tasks (this may be safely interrupted)...
3748 build (dist-olpc2, xorg-x11-proto-devel-7.2-13.olpc2.src.rpm): free
3748 build (dist-olpc2, xorg-x11-proto-devel-7.2-13.olpc2.src.rpm): free -> open (bender.codewiz.org)
3748 build (dist-olpc2, xorg-x11-proto-devel-7.2-13.olpc2.src.rpm): open (bender.codewiz.org) -> FAILED: BuildError: package xorg-x11-proto-devel not in list for tag dist-olpc2
  0 free  0 open  0 done  1 failed

3748 build (dist-olpc2, xorg-x11-proto-devel-7.2-13.olpc2.src.rpm) failed


Not knowing what to do, I tried a scratch build instead, but the server
got stuck, and kojira started spitting these:


2007-10-18 09:50:46,417 [ERROR] koji: Traceback (most recent call last):
  File "/usr/sbin/kojira", line 341, in main
    repomgr.updateRepos()
  File "/usr/sbin/kojira", line 250, in updateRepos
    tstate = koji.TASK_STATES[tinfo['state']]
TypeError: 'NoneType' object is unsubscriptable


I noticed there are mock-config entries in the database.  I was unsure
whether they're supposed to be created automatically, so I tried
creating one manually like so:

$ koji mock-config --arch=i386  --tag=dist-olpc2-build --mockdir=/var/lib/mock/olpc-2-i386 --distribution=dist-olpc2 olpc-2-i386
Could not get a repo for tag: dist-olpc2-build

I couldn't figure out what a correct combination of parameters would be.

Is koji 1.2.2 the version you're really
running on koji.fedoraproject.org?  After some

What else am I overlooking?  I'd be *very* glad if you could dedicate some
of your time to help me on this.  I usually hang out on freenode as _bernie
or _bernie|home.

Thanks.

-- 
 \___/
 |___|   Bernardo Innocenti - http://www.codewiz.org/
  \___\  One Laptop Per Child - http://www.laptop.org/


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]