[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: OOo .odt files - open with Java by default



Caolan McNamara wrote:
On Tue, 2007-10-30 at 22:48 -0500, King InuYasha wrote:
I never install Sun Java. These problems crop up in a default Fedora
install for me.

Where as I have never ever ever seen it. Do you get the same error
message of "if you open this file, the file might present a security
risk to your system"

Since I've had this happening for some time , I think I worked out how to cause it:
F7 updated.
nautilus --browser {actually I change the defaults to view list and open in browser windows}.

The list shows:
ootexticon   whatever.odt   type=ODT document
If you left click the .odt etc, open office writer is spawned, and "it is good".

However, if you actually put the cursor on the file by eg down-down-down in the file list, or by right clicking on the file, the type changes so that it now says:
javaicon     whatever.odt   type=Java Archive

Once this is the case, a left click now generates the warning dialog:
"The filename "the_tint_shop (copy).12149.odt" indicates that this file is of type "ODT document". The contents of the file indicate that the file is of type "Java Archive". If you open this file, the file might present a security risk to your system.

Do not open the file unless you created the file yourself, or received the file from a trusted source. To open the file, rename the file to the correct extension for "Java Archive", then open the file normally. Alternatively, use the Open With menu to choose a specific application for the file. "

Same with a zip file:
archiveicon   whatever.zip   ZIP archive

after cursor on the file:
javaicon     whatever.zip   type=Java Archive


I also see similar for asf file that changes to wmf {or reverse, I forget}.

My explanation {no evidence} is that when you click the file - the file command is run to determine the content type regardless of extension. So it would be this that is badly interpreting it ? That doesn't seem to be the actual case if I run: file on the commands it gives the correct answers.

DaveT.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]