[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Python 3.0



On Sun, 2007-09-02 at 09:50 -0700, Toshio Kuratomi wrote:
> > You do love to split hairs.  It's clear from the minutes that FESCO was
> > concerned that the functionality supplied by Zope should be available to
> > Fedora Infrastructure, and didn't have to rely on F7 to supply it.  The
> > rest of us mortals didn't fare so well.
> > 
> Heh.  If you really want your hairs split, it's really the Fedora
> Documentation Project that wants to use Zope/Plone.  Infrastructure just
> manages the services. :-)

Perhaps it's time to shave my head.

> Since that's not really the information you want, let's look at it this
> another way: Do you have a team of people who are maintaining
> zope/plone/python2.4 right now?  Is it going well?  How do they decide
> which python modules to build for python2.4?  Do they limit the bug
> reports they deal with to bug reports against zope/plone or do they
> handle bugs from people who are running python2.4 for other reasons?

I don't, obviously.  The zope/plone communities do, for zope and plone.
And, the problem for the zope folks in migrating to 2.5 is that the
python developers chose to modify the c/python api for the benefit of a
very few people running simulations using huge datasets on 64-bit
machines.  I don't believe that the actual python syntax changes
presented a problem.  That, of course, is not going to be the case going
to python 3.0 and beyond.

> Most importantly, are they willing to commit to maintaining this stack
> of packages for the life of F-7?

Well, let's see.  Looking in Bugzilla for python on FC6 (2.4), there are
a total of twelve bug reports, five of which are dups, and one was not a
bug.  Of the remaining bugs, two were from rawhide, and the remaing four
are still open (dating from Nov/Dec 2006).  Those were presumably
referred upstream to the python developers.  Given all that, how much
additional activity would you expect for an F7 (and probably F8)
compat-python?

> I'm no longer on FESCo but these were some of the questions that were
> asked that have a technical justification and I highly suspect that the
> current FESCo will listen to the answers to these questions as well when
> deciding whether compat-python can exist within Fedora without putting
> too much extra work on the rest of the distro.

I would think that a bigger concern would be the suitability of python
as a development platform for large projects.  Don't get me wrong, I use
python, and it's great for rapid development.  It's not so great when
the python developers consistently make changes that break compatibility
so that you have to rework the code.

> Finally, I want to keep stressing that FESCo did not ban zope or plone.
>  They discussed what the standard of commitment should be for a person
> or team to maintain a compat-python package in Fedora.  We wanted to
> allow this goal to be met:
> "[including] a wide range of packages that fits into the various
> different needs of the users."

The fact is that the zope/plone developers are going to have to play
catch up for quite some time given the announced intentions of the
python developers.  If you're going to wait for them to get current,
then you have effectively banned them for probably years to come.

> But not at the expense of:
> "[being] on the leading edge of free and open source technology, by
> adopting and helping develop new features and version upgrades."
> and
> "[providing] a robust development platform for building software and
> robust general integrated set of software that balances the needs for
> both desktop and server users."

Ironically, zope/plone IS a robust development platform.

> The questions we wanted answered were to ensure that there was a
> commitment by the packager(s) involved in compat-python2.4 to meet the
> robustness goal for the life of the packages so that people working on
> the leading edge goal didn't have to stop what they were doing and fix
> problems with the compat- packages.

Correct me if I'm wrong, but it looks like there was one update to
python for fc6 going from python-2.4.3-18 on the installation iso to
python-2.4.4-1.  There are still four open bugs on the update.  I'm
guessing that the python developers aren't really jumping to get those
fixed.  Anyway, where is the evidence that such a situation would arise?

> * Goals copied from: http://fedoraproject.org/wiki/Objectives
> * Note: when Jeremy has a chance to reply to these messages he may have
> a different perspective on FESCo's discussions as he was arguing the
> opposite point of view as I was.

Toshio, thank you very much for taking the time to give us your
perspective.  I appreciate it.

Dave



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]