[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: obsoleting in compat packages: is it right?



Le vendredi 07 septembre 2007 à 00:36 +0200, Michael Schwendt a écrit :

> As in the range  1.5.0 <= x < 1.6.0  ?
> I don't think that is possible with "Obsoletes".
> With Requires it is different, since all Requires must be satisfied.

No it's not, since rpm is lacking true version range support you only
need package A providing foo = 1.4.0 and package B foo = 1.8.0 to fool
Requires 1.5.0 <= foo < 1.6.0 


-- 
Nicolas Mailhot

Attachment: signature.asc
Description: Ceci est une partie de message numériquement signée


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]