[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: obsoleting in compat packages: is it right?



On Fri, 07 Sep 2007 00:45:49 +0200, Nicolas Mailhot wrote:

> 
> Le vendredi 07 septembre 2007 à 00:36 +0200, Michael Schwendt a écrit :
> 
> > As in the range  1.5.0 <= x < 1.6.0  ?
> > I don't think that is possible with "Obsoletes".
> > With Requires it is different, since all Requires must be satisfied.
> 
> No it's not, since rpm is lacking true version range support you only
> need package A providing foo = 1.4.0 and package B foo = 1.8.0 to fool
> Requires 1.5.0 <= foo < 1.6.0 

Not that notation. But

  Requires: foo >= 1.5.0
  Requires: foo < 1.6.0

does not work?
It must be

  Requires: foo >= 1.5.0
  Conflicts: foo >= 1.6.0

?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]