[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Circular dep - Re: Exclude Requires for some archs



On Tue, 11 Sep 2007 10:45:02 +0200, Till Maas wrote:

> Hiyas,
> 
> I want to use
> %ifnarch ppc ppc64
> Requires: vbetool
> %endif
> in a package, which should work according to maximum rpm[1] and was suggested 
> by Mamoru Tasaka. Nevertheless koji does not want to build[2] this for 
> ppc(64) because of a missing vbetool. Does someone spot the error in the 
> spec[3]?
> 
> Regards,
> Till
> 
> [1] http://www.rpm.org/max-rpm/s1-rpm-inside-conditionals.html
> [2] http://koji.fedoraproject.org/koji/getfile?taskID=155137&name=root.log

There's a circular dep on pm-utils when building pm-utils.
See bottom of the previous build-job by Peter Jones
for pm-utils-0.99.4-1.fc8.src.rpm

 http://koji.fedoraproject.org/koji/getfile?taskID=154848&name=root.log

 ...
 pciutils                ppc64      2.2.6-3.fc8      core               89 k
 pm-utils                ppc64      0.99.3-11.fc8    core               27 k
 procps                  ppc64      3.2.7-16.1.fc8   core              225 k
 ...

The change with added

  Requires: vbetool

was in post 0.99.3-12.fc8 cvs. So, the pm-utils in the buildroots
requires vbetools for all archs, and build pm-utils requires pm-utils.

> [3] 
> http://cvs.fedoraproject.org/viewcvs/rpms/pm-utils/devel/pm-utils.spec?rev=1.79&view=markup
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]