[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 8 Test 2 Release Notes



On Fri, 2007-09-14 at 21:06 -0400, Jesse Keating wrote:
> Not sure that makes sense.  The problem is it needs to be a library
> specific Require, so that the correct arch package will get dragged
> in.  A requirement on "pulseaudio-lib" just won't cut it as that would
> be satisfied by "pulseaudio-lib.x86_64".  I know there is some work
> going on in rpm5 that will do arch specific provides, maybe even
> requires to, but that is future land that we may pull into rpm.org.
> Until then we need something of a solution for Fedora 8.

Lennart or a flash-plugin guy can tell us for certain what flash-plugin
needs (I've no idea what's in pulseaudio-lib). It's most likely a
library file that it dlopen(3)'s. Perhaps flash-plugin can do a:

Requires: %{_libdir}/libaoss.so.0

or some new virtual package name.

BTW, since flash-plugin is an i386 package, wouldn't a Require:
pulseaudio-lib be enough for it to require the .i386 version?
--

Richi Plana


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]