[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Useless OpenEXR split



$ sudo rpm -e OpenEXR 
error: Failed dependencies:
        OpenEXR = 1.4.0a-5.fc8 is needed by (installed) OpenEXR-libs-1.4.0a-5.fc8.i386

$ sudo rpm -e OpenEXR-libs
error: Failed dependencies:
        libHalf.so.4 is needed by (installed) kdelibs-3.5.7-22.fc8.i386
        libHalf.so.4 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386
        libIex.so.4 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386
        libIlmImf.so.4 is needed by (installed) kdelibs-3.5.7-22.fc8.i386
        libIlmImf.so.4 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386
        libIlmThread.so.4 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386
        libImath.so.4 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386
        OpenEXR-libs = 1.4.0a-5.fc8 is needed by (installed) OpenEXR-1.4.0a-5.fc8.i386

$ rpmls OpenEXR
-rwxr-xr-x  /usr/bin/exrenvmap
-rwxr-xr-x  /usr/bin/exrheader
-rwxr-xr-x  /usr/bin/exrmakepreview
-rwxr-xr-x  /usr/bin/exrmaketiled
-rwxr-xr-x  /usr/bin/exrstdattr
drwxr-xr-x  /usr/share/doc/OpenEXR-1.4.0a
-rw-r--r--  /usr/share/doc/OpenEXR-1.4.0a/AUTHORS
-rw-r--r--  /usr/share/doc/OpenEXR-1.4.0a/ChangeLog
-rw-r--r--  /usr/share/doc/OpenEXR-1.4.0a/LICENSE
-rw-r--r--  /usr/share/doc/OpenEXR-1.4.0a/NEWS
-rw-r--r--  /usr/share/doc/OpenEXR-1.4.0a/README

Why does the -libs package require these tools?
The .spec doesn't answer that question.

In the other direction, there's a hardcoded strict dependency in
addition to the automatic soname deps, creating a circle:

$ rpm -qR OpenEXR|grep EXR
OpenEXR-libs = 1.4.0a-5.fc8

Conclusively, the split is useless.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]