[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 8 Test 2 Release Notes



On Tue, 2007-09-18 at 01:54 +0200, Lennart Poettering wrote:
> I basically just implemented the mentioned libflashsupport.so. Which is
> intended to be an API that can be used to replace the audio output
> interface of Adobe Flash. For now this is enough to get Flash
> working. Eventually it would be preferable if Flash would using PA
> natively. But since the current API will eventually be replaced by
> something called libsydney I have not asked Adobe to move this
> abstraction upstream. The libflashsupport.so solution is good enough
> for the near future.

Sorry. It was the alsa-oss-libs packages requirement that tripped me up.

Let's see if I understand correctly now: flash-plugins tries the
OSS /dev/dsp interface (which didn't work on my system when
alsa-oss-libs.i386 was missing because the OSS emulation doesn't work
without those libs?) and, failing that, tries to find libflashsupport.so
within $PATH or $LD_LIBRARY_PATH, loads it and uses it? (actually, it
might even be preferring that over OSS).

The reason I'm asking is I'm trying to figure out what the best way is
to ensure that there is support for flash-plugins packaging-wise. If PA
isn't installed, then the other alternative requirements should be
installed (either OSS or OSS-emulation by ALSA).
--

Richi Plana


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]