[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: why does yum want xulrunner?



On Wed, 19 Sep 2007 10:20:34 -0400, sean wrote:

> from today:
> 
> yum update
> ............
> --> Finished Dependency Resolution
> Error: Unresolvable requirement libxpcom_core.so()(64bit) for yelp
> Error: Unresolvable requirement gecko-libs = 1.8.1.6 for yelp
> Error: Unresolvable requirement libgtkembedmoz.so()(64bit) for yelp
> Error: Missing Dependency: firefox is needed by package libswt3-gtk2
> Error: Unresolvable requirement gecko-libs = 1.8.1.6 for devhelp
> Error: Unresolvable requirement libgtkembedmoz.so()(64bit) for devhelp
> Error: Unresolvable requirement libgtkembedmoz.so for devhelp
> 
> yum --exclude=xulrunner update works.
> 
> and xulrunner is not installed:
> 
> rpm -q xulrunner
> package xulrunner is not installed

It is not installed, but in the yum metadata it replaces firefox and
at the same time takes away packages capabilities required by other
packages.

The xulrunner package includes things such as

  Provides: gecko-libs = 1.9a7
  Provides: gecko-libs = 1.9

  Provides: libsqlite3.so     <-- ought to be filtered out!

  Obsoletes:      firefox < 2.1

with some required package updates not being available yet.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]