[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Dependency problems in today's updates



On Wed, 2007-09-26 at 14:27 -0400, Thomas J. Baker wrote:
> On Wed, 2007-09-26 at 12:12 -0400, Matthew Saltzman wrote:
> > On Wed, 2007-09-26 at 11:57 -0400, Jesse Keating wrote:
> > > On Wed, 26 Sep 2007 11:06:41 -0400
> > > Matthew Saltzman <mjs CLEMSON EDU> wrote:
> > > 
> > > > Does that mean the workaround is to rpm -e xulrunner?
> > > 
> > > Yes, if you happened to force the installation of xulrunner on the one
> > > day it showed up (with it's broken deps), you need to remove it
> > > manually.
> > 
> > I don't recall forcing anything--it just showed up.
> > 
> > That does fix the Firefox dep, but I still have the other problem: the
> > setroubleshoot update wants selinux-policy-base, which doesn't exist
> > AFAIK.
> > 
> > Thanks.
> >  
> 
> I saw the same thing when updating with pup a few days back. It
> complained about not having the correct version of selinux (along with
> another dependency problem). I hit OK, unselected the other problematic
> rpm, then hit update again and it went through the update fine. It
> happened on all three of my F8T2 systems (two x86_64, one i386). This
> could be a pup bug but generating the conditions to make it occur again
> could be difficult.

I have the latest selinux, AFAIK (selinux-policy-3.0.8-11.fc8 and the
targeted one, and libselinux-2.0.34-3.fc8 and relatives).  Still won't
update setroubleshoot to 0:1.10.5-1.fc8.  Same problem with command-line
yum:

        Missing dependency: selinux-policy-base >= 3.0.7-10 is needed by
        package setroubleshoot.
        
> 
> Thanks,
> 
> tjb
-- 
                Matthew Saltzman

Clemson University Math Sciences
mjs AT clemson DOT edu
http://www.math.clemson.edu/~mjs


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]