[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pm-utils ping-pong upgrade/downgrade problem in F7



Ville Skyttä <ville.skytta <at> iki.fi> writes:
> Etc etc.  Duh.  yum does not appear to be affected by this.  I suppose this 
> could be argued to be a bug either in smart or yum (I don't have that strong 
> opinions about which one it is although yum behaves in the desired way in 
> this particular case)

Synaptic does the right thing too (upgrades pm-utils, installs radeontool and 
vbetool, no ping-pong). IMHO, this is smart trying to be too smart. This 
example shows how automatic downgrading is evil. Yum and apt won't even look at 
old versions of packages unless you force them to (in yum, you also need the 
yum-allowdowngrade plugin to even be able to force it).

        Kevin Kofler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]