[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pm-utils ping-pong upgrade/downgrade problem in F7



On Sat, 29 Sep 2007 11:56:36 +0300, Ville Skyttä wrote:

> On Friday 28 September 2007, Michael Schwendt wrote:
> > On Thu, 27 Sep 2007 22:36:56 +0000 (UTC), Kevin Kofler wrote:
> > > Ville Skyttä writes:
> >
> > When the installed set of packages is not broken, i.e. the latest
> > pm-utils requires the installed radeontool/vbetool pkgs without broken
> > deps, why does Smart even look at the older pm-utils pkg?
> 
> I can see Obsoletes making it hard to decide what's older.  Sure, pm-utils in 
> F7 is older than the one in F7 updates if you only look at the pm-utils EVRs, 
> but the troublemaker unversioned Obsoletes on radeontool and vbetool in the 
> F7 pm-utils also make it newer than radeontool and vbetool in F7 updates and 
> the mess begins.  I suppose if Smart wouldn't consider updating something for 
> which it needs to downgrade something unless explicitly told to, we wouldn't 
> see the problem in this particular case.  Or something :)

We've been recommending _versioned_ Obsoletes for a very long time.
We know that obsoleting packages _non-versioned_ and reintroducing
them later can be trouble-some, in particular when the Obsoletes are
still seen by the depsolver. I don't argue that pm-utils using
non-versioned Obsoletes was a bad decision. But I believe Smart should
not consider the old pm-utils at all unless there is a problem with
the new pm-utils. It resurrects obsolete Obsoletes :) and becomes
confused.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]