[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F8 to Rawhide initscripts error



Mike Chambers wrote:
While using yum on an F8 + updates (as of last night) box, and upgrading
to F9 (current rawhide as of today) I get yum erroring out (or at least
a file conflict error), see below..

Transaction Check Error:
  file /etc/event.d/rc1 conflicts between attempted installs of
initscripts-8.73-1.i386 and event-compat-sysv-0.3.9-14.fc9.noarchon file /etc/event.d/rcS conflicts between attempted installs of
initscripts-8.73-1.i386 and event-compat-sysv-0.3.9-14.fc9.noarch
file /etc/event.d/rcS-sulogin conflicts between attempted installs of
initscripts-8.73-1.i386 and event-compat-sysv-0.3.9-14.fc9.noarch

Error Summary



F9 uses upstart to start and stop services on the different runlevels, on F8 this is done by sysvinit. The event-compat-sysv package provides an a lot of the things that initscripts provided for F8, so this is a case of packages that puts the same files in the filesystem (and rightly so)..

But perhaps event-compat-sysv should "obsolete initscripts" to make this possible? Or are initscripts still used on F9?

/Thomas


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]