[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: best way to fix the regular yum dependency problems with add-on packages from 3rd party repositories



Michael Schwendt wrote:

>>     $ yum update phonon*
>>     Error: Missing Dependency: phonon = 4.2.0-1.fc10 is needed by
>> package phonon-backend-gstreamer-4.2.0-1.fc10.x86_64 (installed)
>> 
> 
> There's  phonon-backend-gst  which is supposed to obsolete that pkg
> (if the Obsoletes/Provides tags in it are correct).

Oops, fixed in phonon-4.2.0-3 (building now).

> The rawhide broken deps checker cannot detect this as it no longer sees
> the old phono-backend-gstreamer. (and I think the repoclosure version that
> is used doesn't handle obsoletes yet anyway)
> 
>>     $ yum update digikam*
>>     Transaction Check Error:
>>   file /usr/share/icons/oxygen/128x128/apps/digikam.png from install of
>> digikam-0.10.0-0.1.beta2.fc10.x86_64 conflicts with file from package
>> oxygen-icon-theme-4.1.0-1.fc10.noarch
> 
> Conflicts are not dependency issues and are not checked for.

blarg.  easyfix too, forthcoming.

-- Rex



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]