[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: RFC: best way to fix the regular yum dependency problems with add-on packages from 3rd party repositories



If you like an opinion, it is that Conflicts are difficult to mantain also for a knowledge packager. There
are reason for conflicts but, no matter when, it is best, if possible, to try to rename the package via obsoletes/Provides.
Only an opinion.

Regards

On Sat, Aug 2, 2008 at 4:05 PM, Michael Schwendt <mschwendt gmail com> wrote:
On Sat, 02 Aug 2008 09:41:33 -0400, John Ellson wrote:

> Thorsten Leemhuis wrote:
> > Hi all!
> >
> > About one or two times a month a lot of people run into decency
> > problems like this:
> >
> >>
> >> Error: Missing Dependency: kernel-uname-r = 2.6.25.11-97.fc9.i686 is
> >> needed by
> >> package kmod-nvidia-2.6.25.11-97.fc9.i686-173.14.09-5.lvn9.i686 (livna)
>
> Every day I run into dependency problems like this, just with Rawhide
> rpms, not even third part ones:
>
>     $ yum update phonon*
>     Error: Missing Dependency: phonon = 4.2.0-1.fc10 is needed by
> package phonon-backend-gstreamer-4.2.0-1.fc10.x86_64 (installed)
>

There's  phonon-backend-gst  which is supposed to obsolete that pkg
(if the Obsoletes/Provides tags in it are correct).

The rawhide broken deps checker cannot detect this as it no longer sees
the old phono-backend-gstreamer. (and I think the repoclosure version that
is used doesn't handle obsoletes yet anyway)

>     $ yum update digikam*
>     Transaction Check Error:
>   file /usr/share/icons/oxygen/128x128/apps/digikam.png from install of
> digikam-0.10.0-0.1.beta2.fc10.x86_64 conflicts with file from package
> oxygen-icon-theme-4.1.0-1.fc10.noarch

Conflicts are not dependency issues and are not checked for.

> Neither of these dependency issues is flagged in: "rawhide report:
> 20080802 changes"



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]