[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Conflicts in Rawhide i386 (part 2)



On Sat, Aug 02, 2008 at 10:36:34PM +0200, Michael Schwendt wrote:
> coq-8.1pl3-2.fc10.i386
>   File conflict with: coda-client-6.9.4-0.1.rc2.fc10.i386
>      /usr/bin/parser

Hmmm, I thought that was going to happen.

  https://bugzilla.redhat.com/show_bug.cgi?id=450323#c16

Down at the bottom of that comment I said:

  BTW having a binary called /usr/bin/parser is probably a bad idea.
  How do Debian package this file?  They usually rename such generic
  names ('coqparser' or the like).  If Debian rename it, then we should
  do so too.

We checked Debian, and in fact they ship this as /usr/bin/parser too,
which is why we left it.

Not sure what is the best thing to do here:

(1) Rename it and thus be inconsistent with both upstream & Debian.

(2) Rename Coda's "parser" (breaking things?)

(3) Leave it and tell people that they can't install both packages at
once(!)

Rich.


-- 
Richard Jones, Emerging Technologies, Red Hat  http://et.redhat.com/~rjones
Read my OCaml programming blog: http://camltastic.blogspot.com/
Fedora now supports 59 OCaml packages (the OPEN alternative to F#)
http://cocan.org/getting_started_with_ocaml_on_red_hat_and_fedora


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]