[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Broken dependencies in Fedora 9 - 2008-08-08



On Fri, 08 Aug 2008 04:16:28 -0700, J. Randall Owens wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> Michael Schwendt wrote:
> | Summary of broken packages (by owner):
> |
> |     ebmunson AT us.ibm.com
> |         lsvpd-1.6.4-1.fc9.i386
> |         lsvpd-1.6.4-1.fc9.ppc
> |         lsvpd-1.6.4-1.fc9.ppc64
> |         lsvpd-1.6.4-1.fc9.x86_64
> |
> 
> These are caused by a bug I reported about a month and a half ago, libvpd's
> library numbers got bumped down in the 2.0.2 release.
> https://bugzilla.redhat.com/show_bug.cgi?id=452851
> 
> There's been no action on it since then;

The corresponding update in bodhi was this:
https://admin.fedoraproject.org/updates/F9/FEDORA-2008-4187

Effectively, this soname problem has been reported in two places.

> I'm not sure whether it should be
> against lsvpd, which would just need a rebuild with the new library number, or
> to get libvpd's library number back where it was (assuming it's binary compatible).
> 

libvpd 2.0.0 had major version 0, libvpd 2.0.1 bumped to major version 1,
then they reverted that in 2.0.2. Meanwhile 2.0.3 is available and stays
at major version 0.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]