[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

bodhi template changed?



The bodhi template for use from cvs checkouts seems to have changed recently and bodhi-client-0.4.10-4.fc9 doesn't like it: if I try to submit an update (via "make update") and set the "type" to "enhancement" (which is defined in the template) then I get the fairly cryptic error:

Reading from bodhi.template
Traceback (most recent call last):
  File "/usr/bin/bodhi", line 316, in <module>
    bodhi.parse_file(opts)
  File "/usr/bin/bodhi", line 213, in parse_file
    opts.type = types[para.upper()]
KeyError: 'ENHANCEMENT'

I assume by this that "enhancement" is not a valid value?
(NB either way, bodhi ought to give a clearer error)

Tim


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]