[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: libgnutls-openssl and real openssl conflict



On Mon, 2008-08-25 at 20:04 +0200, Hans de Goede wrote:
> > Hi All,
> > 
> > The story begins here:
> > https://bugzilla.redhat.com/show_bug.cgi?id=446860
...
> > I would like to suggest the removal of libgnutls-openssl from 
> > Fedora,...

That will probably create many legal problems.
If there's a way to keep this package, we should.

As many of you know, the basic problem is that the OpenSSL license
is incompatible with the GPL:
http://www.fsf.org/licensing/licenses/
http://www.gnome.org/~markmc/openssl-and-the-gpl.html
http://www.mail-archive.com/debian-bugs-dist lists debian org/msg426067.html
http://lists.debian.org/debian-legal/2002/10/msg00113.html

Any program that links to libgnutls-openssl that has GPL'ed components
probably CANNOT be legally linked to OpenSSL.

--- David A. Wheeler


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]