[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

mock errors



Hi,

I on occasion get the following errors when running mock to do with DB
errors. It seems to happen when I add the koji repo but this time its
not enabled and I've even removed the contents of the entire mock
build dir and I still get the error. Can anyone shed any light on this
issue?

Peter

INFO: Results and/or logs in: /var/lib/mock//fedora-rawhide-x86_64/result
ERROR: Command failed:
 # /usr/bin/yum --installroot
/var/lib/mock/fedora-rawhide-x86_64/root/  resolvedep  ccache
'libsoup-devel >= 2.4' 'NetworkManager-devel' 'GConf2-devel'
'gtk2-devel' 'libxml2-devel' 'pkgconfig' 'libglade2-devel'
'glib2-devel' 'dbus-glib-devel'
rpmdb: Program version 4.3 doesn't match environment version
error: db4 error(-30974) from dbenv->open: DB_VERSION_MISMATCH:
Database environment version mismatch
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in
/var/lib/mock/fedora-rawhide-x86_64/root/var/lib/rpm


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]