[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Round 3 starting



On Mon, 2008-12-01 at 15:09 +0000, Pádraig Brady wrote:
> Ignacio Vazquez-Abrams wrote:
> > This round is composed of packages that contain compiled Python code but
> > do not have a Requires of python(abi). Please note that this is a
> > packaging bug as the bytecode is specific to the version of the Python
> > it was compiled with. Whether this is a problem with rpm's macros or
> > with the package itself must be dealt with on a case-by-case basis.
> > 
> > fslint
> 
> /usr/share/fslint/fslint/supprt/rmlint/fixdup.py
> /usr/share/fslint/fslint/supprt/rmlint/fixdup.pyc
> /usr/share/fslint/fslint/supprt/rmlint/fixdup.pyo
> 
> fixdup.py is a small support script that I don't
> want a precompiled version of as it's not imported.

If it's just a small support script, then you're better off having it
named 'fixdup' as opposed to 'fixdup.py'.  It avoids things like this
and it also keeps you one step removed from implementation details.  

Jeremy


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]