[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Heads-up: Enabling generation of pkg-config requires



On Mon, 1 Dec 2008, Todd Zullinger wrote:

Panu Matilainen wrote:
Just a heads-up, I'm (finally) enabling the generation of automatic
pkg-config and libtool requires in rpm. Provides for these have been
generated since first rpm 4.6.0 alpha hit rawhide, so with a bit of
luck, all/most involved packages have been rebuilt since then and
already have  the needed provides for satisfying the new requires.

But if you see unsatisfied dependencies on pkgconfig(foo) and
libtool(foo), request a rebuild of the dependant package, that's all
it  should take. Except if you happen to hit a big chain of
pkg-config using  packages that haven't been rebuilt in several
months, or bugs in the  dependency generation, or buggy pkg-config
.pc files...

A recent build of gtkpod failed to install libgpod-develĀ¹, which
requires pkgconfig(gobject-2.0).  Shouldn't glib2-devel provide that?
It's certainly been rebuilt recently, yet the only pkgconfig provides
it has is pkgconfig(glib-2.0).  The latest glib2-devel package has a
number of .pc files though:

$ rpm -qpl glib2-devel-2.19.1-2.fc11.i386.rpm | grep '\.pc$'
/usr/lib/pkgconfig/gio-2.0.pc
/usr/lib/pkgconfig/gio-unix-2.0.pc
/usr/lib/pkgconfig/glib-2.0.pc
/usr/lib/pkgconfig/gmodule-2.0.pc
/usr/lib/pkgconfig/gmodule-export-2.0.pc
/usr/lib/pkgconfig/gmodule-no-export-2.0.pc
/usr/lib/pkgconfig/gobject-2.0.pc
/usr/lib/pkgconfig/gthread-2.0.pc

So, is this a bug in the libgpod packaging or in the rpm pkgconfig
provides stuff?

Bug in rpm pkgconfig generation, see https://bugzilla.redhat.com/show_bug.cgi?id=473814

	- Panu -


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]