[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: The looming Python 3(000) monster



On 2008-12-05, 14:42 GMT, Michael DeHaan wrote:
> I personally haven't tried it yet, but it /aims/ to be 
> incompatble, which is perhaps one of the most glaring signs 
> a language designer has lost it that I've seen.

Guido was preparing on this incompatibility for years, so unless 
you were sleeping you should not be surprised.

> but it's pretty bad for someone who wants to keep a single 
> codebase across EL 4 (Python 2.3) and up, which I think a lot 
> of us do.

The party line is that you should develop against python 2.6 
(which doesn't block you from being compatible with Python 2.3) 
and then conversion from 2.6 to 3.* would be guaranteed to be 
done just with a script.

Matěj


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]