[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Work needed, how you can help!



On Sun, 07 Dec 2008 13:22:46 -0800, Jesse wrote:

> The work needed is for somebody to examine all the packages in rawhide
> that provide .pc files and ensure proper placement of them based on the
> review guideline.  This will likely require interaction with the
> packages maintainer(s) so the first step should probably be to produce a
> list of packages that ship .pc in a non -devel package and send the list
> (sorted by maintainer) to here so that we can discuss and pick off
> items.

Here are some different details. The following list shows:

 * non-devel packages that include .pc files
 * any virtual -devel package names
 * the dependencies on other packages, which provide .pc files


=> 1:control-center-2.25.2-4.fc11.i386 (control-center-2.25.2-4.fc11.src.rpm)
    /usr/share/pkgconfig/gnome-default-applications.pc
    /usr/share/pkgconfig/gnome-keybindings.pc
    REQUIRES: gnome-icon-theme
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info
    REQUIRES: gtk2-engines
    REQUIRES: gtk2-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: atk-devel
    REQUIRES: gtk-doc
    REQUIRES: glib2-devel
    REQUIRES: libXrandr-devel
    REQUIRES: pango-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: fontconfig-devel
    REQUIRES: libXft-devel
    REQUIRES: libXext-devel
    REQUIRES: libXcomposite-devel
    REQUIRES: libXfixes-devel
    REQUIRES: libXcursor-devel
    REQUIRES: libXi-devel
    REQUIRES: libXinerama-devel

=> 1:emacs-el-22.3-2.fc11.i386 (emacs-22.3-2.fc11.src.rpm)
    /usr/share/pkgconfig/emacs.pc

=> 1:xorg-x11-font-utils-7.2-6.fc10.i386 (xorg-x11-font-utils-7.2-6.fc10.src.rpm)
    /usr/lib/pkgconfig/fontutil.pc

=> avahi-sharp-0.6.22-13.fc11.i386 (avahi-0.6.22-13.fc11.src.rpm)
    /usr/lib/pkgconfig/avahi-sharp.pc
    REQUIRES: libgdiplus-devel

=> avahi-ui-sharp-0.6.22-13.fc11.i386 (avahi-0.6.22-13.fc11.src.rpm)
    /usr/lib/pkgconfig/avahi-ui-sharp.pc
    REQUIRES: avahi-sharp
    REQUIRES: libgdiplus-devel

=> bodr-8-1.fc9.noarch (bodr-8-1.fc9.src.rpm)
    /usr/share/pkgconfig/bodr.pc

=> chemical-mime-data-0.1.94-3.fc8.noarch (chemical-mime-data-0.1.94-3.fc8.src.rpm)
    /usr/share/pkgconfig/chemical-mime-data.pc
    REQUIRES: shared-mime-info

=> compiz-bcop-0.7.8-1.fc11.noarch (compiz-bcop-0.7.8-1.fc11.src.rpm)
    /usr/share/pkgconfig/bcop.pc

=> deskbar-applet-2.25.1-5.fc11.i386 (deskbar-applet-2.25.1-5.fc11.src.rpm)
    /usr/lib/pkgconfig/deskbar-applet.pc
    REQUIRES: pygtk2-devel
    REQUIRES: pygobject2-devel
    REQUIRES: glib2-devel
    REQUIRES: pycairo-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: fontconfig-devel
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info
    REQUIRES: gnome-icon-theme
    REQUIRES: gtk2-engines
    REQUIRES: gtk2-devel
    REQUIRES: atk-devel
    REQUIRES: gtk-doc
    REQUIRES: libXrandr-devel
    REQUIRES: pango-devel
    REQUIRES: libXft-devel
    REQUIRES: libXext-devel
    REQUIRES: libXcomposite-devel
    REQUIRES: libXfixes-devel
    REQUIRES: libXcursor-devel
    REQUIRES: libXi-devel
    REQUIRES: libXinerama-devel
    REQUIRES: gnome-python2-desktop

=> flumotion-0.4.2-7.fc11.i386 (flumotion-0.4.2-7.fc11.src.rpm)
    /usr/lib/pkgconfig/flumotion.pc
    REQUIRES: gstreamer-python
    REQUIRES: pygtk2-devel
    REQUIRES: pygobject2-devel
    REQUIRES: glib2-devel
    REQUIRES: pycairo-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: fontconfig-devel
    REQUIRES: gstreamer-devel
    REQUIRES: libxml2-devel
    REQUIRES: check-devel

=> freehdl-0.0.6-2.fc10.i386 (freehdl-0.0.6-2.fc10.src.rpm)
    /usr/lib/pkgconfig/freehdl.pc

=> gmime-sharp-2.4.3-2.fc11.i386 (gmime-2.4.3-2.fc11.src.rpm)
    /usr/lib/pkgconfig/gmime-sharp-2.4.pc
    REQUIRES: libgdiplus-devel

=> gnome-doc-utils-stylesheets-0.14.0-4.fc11.noarch (gnome-doc-utils-0.14.0-4.fc11.src.rpm)
    /usr/share/pkgconfig/gnome-doc-utils.pc
    /usr/share/pkgconfig/xml2po.pc
    REQUIRES: libxml2-devel

=> gnome-icon-theme-2.24.0-1.fc10.noarch (gnome-icon-theme-2.24.0-1.fc10.src.rpm)
    /usr/share/pkgconfig/gnome-icon-theme.pc

=> gnome-mime-data-2.18.0-3.fc10.noarch (gnome-mime-data-2.18.0-3.fc10.src.rpm)
    /usr/share/pkgconfig/gnome-mime-data-2.0.pc

=> gnome-python2-desktop-2.24.0-5.fc11.i386 (gnome-python2-desktop-2.24.0-5.fc11.src.rpm)
    /usr/lib/pkgconfig/gnome-python-desktop-2.0.pc
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info

=> gnome-python2-extras-2.19.1-26.fc11.i386 (gnome-python2-extras-2.19.1-26.fc11.src.rpm)
    /usr/lib/pkgconfig/gnome-python-extras-2.0.pc
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info

=> gnome-screensaver-2.25.1-2.fc11.i386 (gnome-screensaver-2.25.1-2.fc11.src.rpm)
    /usr/lib/pkgconfig/gnome-screensaver.pc
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info
    REQUIRES: gnome-icon-theme
    REQUIRES: gtk2-engines
    REQUIRES: gtk2-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: atk-devel
    REQUIRES: gtk-doc
    REQUIRES: glib2-devel
    REQUIRES: libXrandr-devel
    REQUIRES: pango-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: fontconfig-devel
    REQUIRES: libXft-devel
    REQUIRES: libXext-devel
    REQUIRES: libXcomposite-devel
    REQUIRES: libXfixes-devel
    REQUIRES: libXcursor-devel
    REQUIRES: libXi-devel
    REQUIRES: libXinerama-devel

=> gstreamer-python-0.10.12-2.fc11.i386 (gstreamer-python-0.10.12-2.fc11.src.rpm)
    PROVIDES: gstreamer-python-devel
    /usr/lib/pkgconfig/gst-python-0.10.pc
    REQUIRES: pygtk2-devel
    REQUIRES: pygobject2-devel
    REQUIRES: glib2-devel
    REQUIRES: pycairo-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: fontconfig-devel
    REQUIRES: gstreamer-devel
    REQUIRES: libxml2-devel
    REQUIRES: check-devel

=> gtk-doc-1.11-2.fc11.noarch (gtk-doc-1.11-2.fc11.src.rpm)
    /usr/share/pkgconfig/gtk-doc.pc

=> gtk-sharp2-gapi-2.12.5-1.fc11.i386 (gtk-sharp2-2.12.5-1.fc11.src.rpm)
    /usr/lib/pkgconfig/gapi-2.0.pc

=> gtk2-engines-2.17.1-1.fc11.i386 (gtk2-engines-2.17.1-1.fc11.src.rpm)
    /usr/lib/pkgconfig/gtk-engines-2.pc
    REQUIRES: gtk2-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: atk-devel
    REQUIRES: gtk-doc
    REQUIRES: glib2-devel
    REQUIRES: libXrandr-devel
    REQUIRES: pango-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: fontconfig-devel
    REQUIRES: libXft-devel
    REQUIRES: libXext-devel
    REQUIRES: libXcomposite-devel
    REQUIRES: libXfixes-devel
    REQUIRES: libXcursor-devel
    REQUIRES: libXi-devel
    REQUIRES: libXinerama-devel

=> icon-naming-utils-0.8.7-1.fc10.noarch (icon-naming-utils-0.8.7-1.fc10.src.rpm)
    /usr/share/pkgconfig/icon-naming-utils.pc

=> libXaw-compat-1.0.4-3.fc10.i386 (libXaw-1.0.4-3.fc10.src.rpm)
    /usr/lib/pkgconfig/xaw6.pc

=> nfs-utils-lib-1.1.4-1.fc10.i386 (nfs-utils-lib-1.1.4-1.fc10.src.rpm)
    /usr/lib/pkgconfig/libnfsidmap.pc
    /usr/lib/pkgconfig/librpcsecgss.pc

=> notify-python-0.1.1-5.fc11.i386 (notify-python-0.1.1-5.fc11.src.rpm)
    /usr/lib/pkgconfig/notify-python.pc

=> pygoocanvas-0.10.0-3.fc11.i386 (pygoocanvas-0.10.0-3.fc11.src.rpm)
    /usr/lib/pkgconfig/pygoocanvas.pc
    REQUIRES: pygtk2-devel
    REQUIRES: pygobject2-devel
    REQUIRES: glib2-devel
    REQUIRES: pycairo-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: fontconfig-devel

=> python-gtkextra-1.1.0-3.fc10.i386 (python-gtkextra-1.1.0-3.fc10.src.rpm)
    /usr/lib/pkgconfig/python-gtkextra.pc

=> samba-common-3.2.5-0.23.fc11.i386 (samba-3.2.5-0.23.fc11.src.rpm)
    /usr/lib/pkgconfig/netapi.pc

=> shared-mime-info-0.51-5.fc11.i386 (shared-mime-info-0.51-5.fc11.src.rpm)
    /usr/share/pkgconfig/shared-mime-info.pc

=> tomboy-0.13.1-5.fc11.i386 (tomboy-0.13.1-5.fc11.src.rpm)
    /usr/lib/pkgconfig/tomboy-addins.pc
    REQUIRES: libgdiplus-devel
    REQUIRES: gnome-mime-data
    REQUIRES: shared-mime-info
    REQUIRES: gnome-icon-theme
    REQUIRES: gtk2-engines
    REQUIRES: gtk2-devel
    REQUIRES: libX11-devel
    REQUIRES: libXdmcp-devel
    REQUIRES: xorg-x11-proto-devel
    REQUIRES: mesa-libGL-devel
    REQUIRES: libXau-devel
    REQUIRES: libxcb-devel
    REQUIRES: atk-devel
    REQUIRES: gtk-doc
    REQUIRES: glib2-devel
    REQUIRES: libXrandr-devel
    REQUIRES: pango-devel
    REQUIRES: cairo-devel
    REQUIRES: freetype-devel
    REQUIRES: pixman-devel
    REQUIRES: libpng-devel
    REQUIRES: libXrender-devel
    REQUIRES: fontconfig-devel
    REQUIRES: libXft-devel
    REQUIRES: libXext-devel
    REQUIRES: libXcomposite-devel
    REQUIRES: libXfixes-devel
    REQUIRES: libXcursor-devel
    REQUIRES: libXi-devel
    REQUIRES: libXinerama-devel
    REQUIRES: xorg-x11-font-utils

=> ustr-debug-1.0.4-7.fc10.i386 (ustr-1.0.4-7.fc10.src.rpm)
    /usr/lib/pkgconfig/ustr-debug.pc
    REQUIRES: ustr-devel

=> xcb-proto-1.2-3.fc11.noarch (xcb-proto-1.2-3.fc11.src.rpm)
    /usr/share/pkgconfig/xcb-proto.pc

=> xorg-x11-xbitmaps-1.0.1-6.fc10.i386 (xorg-x11-xbitmaps-1.0.1-6.fc10.src.rpm)
    PROVIDES: xbitmaps-devel
    /usr/lib/pkgconfig/xbitmaps.pc


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]