[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: eel2 is going away



On Tue, 2008-12-16 at 11:37 +0100, Dominik 'Rathann' Mierzejewski wrote:
> On Tuesday, 16 December 2008 at 08:15, Matthias Clasen wrote:
> > eel2 has been merged back into nautilus, and will no longer be available
> > as a separate library. I've added an Obsoletes to the nautilus package.
> > 
> > This only affects a handful of packages, and for most of them a simple
> > rebuild should suffice:
> > 
> > $repoquery -q --whatrequires libeel-2.so.2
> > nautilus-python-0:0.5.1-1.fc10.i386
> > control-center-1:2.24.0.1-9.fc10.i386
> > nautilus-cd-burner-0:2.24.0-1.fc10.i386
> > nautilus-share-0:0.7.2-13.fc10.i386
> > gnome-translate-0:0.99-12.fc9.i386
> > nautilus-search-tool-0:0.2.2-4.fc10.i386
> 
> IIUC, it's just the library moving from eel2 package to nautilus, right?
> So why would the packages need a rebuild? The specfiles may need updating
> to use nautilus-devel instead of eel2-devel, but I'd say a rebuild just
> for that reason is unnecessary.

No, there's no installed library anymore. libeel is merged into
libnautilus-private, which is just a convenience library, not something
thats available for linking against.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]