[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: wxGTK2 -> wxGTK rename without Provides



On Thu, 18 Dec 2008 12:09:06 +0100, Dan wrote:

> > For example, in KDE SIG we're telling folks to keep using qt4-devel and
> > kdelibs4-devel and we have no plans to drop those virtual Provides.
> 
> The wxWidgets API should be stable over all GUI toolkits used (GTK,
> Cocoa, X, MSWin, ...). And there were probably some
> differences/incompatibilities between wxWidgets build against GTK 1 and
> wxWidgets built against GTK 2, that lead the audacity developers to
> require the GTK 2 version.

It's the opposite.

The stable release series of Audacity, 1.2.x, is made for the GTK+ 1
version of wxWidgets. The beta releases have closed the gap and are made
for and tested with "wxWidgets 2", albeit for quite some time not the very
latest. Meanwhile the requirement is wxWidgets 2.8.x.

We used to have wxGTK, wxGTK2, compat-wxGTK, compat-wxGTK2, and
compat-wxGTK26, not just because of Audacity.

IMO, there is no need to keep virtual package names forever.  If a package
gets renamed after years, the BuildRequires in other packages can be
adjusted accordingly.

What I'd like to see, however, is that this is done with an announcement
and not for old branches. Else we offer source rpms with broken Requires.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]