[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: search for BuildRequires using repoquery





On Thu, 18 Dec 2008, Dan Horák wrote:

Seth Vidal píše v Čt 18. 12. 2008 v 09:06 -0500:

On Thu, 18 Dec 2008, Dan Horák wrote:

Hi,

the manpage for repoquery says that is is possible to search for
BuildRequires using this command:

repoquery --archlist=src --whatrequires gail-devel

But it gives me a traceback. Is it still supposed to work? There was
also a thread on yum-devel about searching BuildRequires -
http://lists.baseurl.org/pipermail/yum-devel/2006-May/002187.html



What traceback does it give you?

yum-utils-1.1.18-2.fc10.noarch

[dan eagle ~]$ repoquery --archlist=src --whatrequires wxGTK2-devel
Traceback (most recent call last):
 File "/usr/bin/repoquery", line 853, in <module>
   main(sys.argv)
 File "/usr/bin/repoquery", line 849, in main
   repoq.runQuery(regexs)
 File "/usr/bin/repoquery", line 503, in runQuery
   for p in self.doQuery(oper, prco): print p
 File "/usr/bin/repoquery", line 508, in doQuery
   return getattr(self, "fmt_%s" % method)(*args, **kw)
 File "/usr/bin/repoquery", line 545, in fmt_whatrequires
   require_recursive(name)
 File "/usr/bin/repoquery", line 540, in require_recursive
   for pkg in self.pkgSack.searchRequires(prov.split()[0]):
 File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 592, in
<lambda>
   pkgSack = property(fget=lambda self: self._getSacks(),
 File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 417, in
_getSacks
   if self._pkgSack and thisrepo is None:
 File "/usr/lib/python2.5/site-packages/yum/packageSack.py", line 263,
in __len__
   ret += len(sack)
ValueError: __len__() should return >= 0


Do you want a bug?


sure, but before you do, try yum-utils 1.1.19 which just hit updates-testing.

-sv

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]