[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Automatic BuildRequires



On Fri, 19 Dec 2008 15:42:35 -0700, Jerry wrote:

> On Thu, Dec 18, 2008 at 5:41 AM, Karsten Hopp wrote:
> > I've used auto-br-rpmbuild with my latest full-install mass rebuild and
> > grepped the
> > BuildRequires from the logs.
> > They are available at
> >        http://karsten.fedorapeople.org/buildrequires/
> 
> I'm not sure what to do with this information.  For example, take a
> look at one of my packages: automaton.  It's a Java package.  Yet your
> logs show gstreamer-devel as a BuildRequires.  How did that get in
> there?

A bug. compface also lists gstreamer-devel as a BR, which isn't true.

There are more problems. For example:

xmms-sid (an input plugin for XMMS) lists lots of packages, which
are completely unrelated to the plugin and xmms. Not limited to
wine-core, xulrunner, qt3, libvirt-cim, inn, kdelibs*, mysql-libs,
octave, ogre, ...

Same for sylpheed.
Same for pth.
Same for audacious-plugin-fc.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]