[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: yum multilib_policy default for F9



Matt Domsch wrote:
Seth added a new feature to yum, letting one specify the multilib
policy system-wide.  This is similar to the yum-basearchonly plugin,
only better integrated into yum itself.

multilib_policy=all  (current default, matches F8 and earlier behavior)
  'yum install firefox' will install firefox.i386 and firefox.x86_64
  on an x86_64 system.

multilib_policy=best  (desired behavior IMHO)
  'yum install firefox' will install firefox.x86_64 on an x86_64
  system.  'yum install firefox.i386' will install firefox.i386.

Depsolving still happens as expected, so installing an .i386 app with
'yum localinstall foo.i386.rpm' will depsolve and pull in any .i386
dependencies.


What are the objections, besides timing (Alpha is finished, Beta is ~1
month away) to switching the default from 'all' to 'best' for F9?



multilib_policy=best as default gets a +1 from me


Regards,

Hans


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]