[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Packaging: name changes?



On Tuesday 05 February 2008 11:51:58 pm Kelly Miller wrote:
> Ignacio Vazquez-Abrams wrote:
> > http://fedoraproject.org/wiki/Packaging/DistTag
>
> So, something like this?

Something like that, but I'd suggest a few enhancements.

> %if 0%{?fedora} <= 8
> BuildRequires:  kdelibs-devel >= 3.0.0, kdebase-devel >= 3.0.0
> Requires:       kdebase

All supported distros have kdefoo-devel > 3, no need to have that BR 
versioned. The only versioning I'd consider adding is kdefoo-devel < 4, to 
make sure someone doesn't try building against kde4 bits (like on a part f8, 
part rawhide system or some such thing).

> %else
> BuildRequires:  kdelibs3-devel >= 3.0.0, kdebase3-devel >= 3.0.0
> Requires:       kdebase3
> %endif

Again, no need to have the BR versioned. kdefoo3-devel is definitely going to 
be 3.something.


-- 
Jarod Wilson
jwilson redhat com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]