[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Packaging: name changes?



On Wednesday 06 February 2008 05:51:58 Kelly Miller wrote:
> Ignacio Vazquez-Abrams wrote:
> > http://fedoraproject.org/wiki/Packaging/DistTag
>
> So, something like this?
>
> %if 0%{?fedora} <= 8
> BuildRequires:  kdelibs-devel >= 3.0.0, kdebase-devel >= 3.0.0
> Requires:       kdebase
> %else
> BuildRequires:  kdelibs3-devel >= 3.0.0, kdebase3-devel >= 3.0.0
> Requires:       kdebase3
> %endif

The following will work on both F-8 and devel:

  BuildRequires:  kdelibs3-devel, kdebase3-devel
  Requires:       kdebase3

because kdebase and kdelibs, in F-8, have Provides: kdebase3 and so on.

-- 
Laurent Rineau
http://fedoraproject.org/wiki/LaurentRineau


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]