[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: call for brave ext4 testers in F9, with caveats



Jeffrey Ollie wrote:
> On 2/4/08, Eric Sandeen <sandeen redhat com> wrote:
>> 3) misc stuff - I've not yet tested ext4 over an encrypted block device,
>> or even over an lvm volume.  There may be some stack issues on x86 boxes
>> still, I'm working on slimming that down.  I hope that more real-world
>> use will shake out any remaining problems.
> 
> I temporarily lost my sanity and tried installing ex4 over an
> encrypted lvm volume.  Of course, it didn't work, I get the following
> message when it tried to mount the root partition:
> 
> EXT4-fs: dm-1: not marked OK to use with test code

welcome to the bleeding edge; this is a new check that went into the
most recent kernels.  But it's ok, really:

Get e2fsprogs 1.40.5 from rawhide, boot up your rescue disk, and:

[root]# debugfs -w /dev/<whatever>
debugfs 1.40.5 (27-Jan-2008)
debugfs:  set_super_value s_flags 4
debugfs:  quit

and you'll be fine.

I've also got this info at http://fedoraproject.org/wiki/FedoraExt4; if
anyone is having ext4 trouble please look there first.

This is a safety check put in to make sure that ext3 never unexpectedly
gets mounted with ext4dev (_development_) code.

Thanks,
-Eric

> I have a pictures of the last couple screens of boot messages (taken
> with my cell phone but readable) - are there any other post-mortem
> operations I should do before reformatting and trying something more
> sane?  BTW, this is with kernel 2.6.24-23.fc9 (I added a rawhide http
> repo during the install to get the latest updates - I told you I
> wasn't thinking straight when I started this experiment...)
> 
> Jeff
> 


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]