[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: call for brave ext4 testers in F9, with caveats



On 2/8/08, Eric Sandeen <sandeen redhat com> wrote:
> Eric Sandeen wrote:
> > Jeffrey Ollie wrote:
> >> On 2/4/08, Eric Sandeen <sandeen redhat com> wrote:
> >>> 3) misc stuff - I've not yet tested ext4 over an encrypted block device,
> >>> or even over an lvm volume.  There may be some stack issues on x86 boxes
> >>> still, I'm working on slimming that down.  I hope that more real-world
> >>> use will shake out any remaining problems.
> >> I temporarily lost my sanity and tried installing ex4 over an
> >> encrypted lvm volume.  Of course, it didn't work,
>
> Oh, ye of little faith! :)

I had enough faith to try :)!!!

> >> I get the following
> >> message when it tried to mount the root partition:
>
> FWIW, if you did this with all rawhide bits, it *should* have worked;
> (rawhide) anaconda should have called (rawhide) mkfs.ext3 in a manner
> which should have set the flag that the (rawhide) kernel is looking for.
>
> This was not the case?

No, anaconda would have been from the F9 alpha DVD, so probably
wouldn't have done that.  I think that I shot myself in the foot by
booting off of the F9 alpha DVD and then adding a rawhide http repo to
pull in the latest bits.

I was trying out your advice to use a rescue CD (actually the F9 alpha
DVD again) to use the latest debugfs to set the flag, but that is
complicated by the fact that my physical volume is encrypted.  Does
the rescue mode have the tools necessary to mount encrypted
partitions?

Anyway, I think I'll get a boot.iso from rawhide and reinstall using that...

Jeff


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]