[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: xine-lib in rawhide not buildable against?





2008/2/8 Martin Sourada <martin sourada gmail com>:
Hi,

I have problems with rebuilding gxine for gcc 4.3 [0]. Seems like
xine-lib is at fault as the build [1] fails on configure:

checking for XINE-LIB version >= 1.0.1...
*** 'xine-config --version' returned 1.1.10, but XINE (10.-238096384.0)
*** was found! If xine-config was correct, then it is best
*** to remove the old version of XINE. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If xine-config was wrong, set the environment variable XINE_CONFIG
*** to point to the correct copy of xine-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** Please install xine-lib (devel) first ***

looking at root.log [2] the xine-lib version is:

xine-lib-devel          x86_64     1.1.10.1-1.fc9   build             282 k

Any idea what's wrong there?


Yes. xine-lib-1.1.10.1 has a broken installation.
Its plugins are installed in %{_libdir}/xine/plugins/1.1.10
and not in 1.1.10.1 subdir as it should.
 

--
Paulo Roma Cavalcanti
LCG - UFRJ
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]