[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Git has too many freaking dependencies



On Fri, Feb 15, 2008 at 11:13:45AM -0500, Yaakov Nemoy wrote:
> Hey list,
> 
> Before I go and submit a bug, I would like to ask why git requires
> that i install so many dependencies?  Apparently, to manage files, git
> requires no less than CVS, Subversion, emacs-common and emacs-git, and
> tk.  Below is a log from yum.  I'm not complaining too much as I will
> need these tools too, but it strikes me as very odd that git requires
> that I have not only a working kitchen sink, but a dishwasher, and
> servants to load it every day.
[...]
> ---> Package git.i386 0:1.5.3.8-1.fc8 set to be updated
> --> Processing Dependency: git-cvs = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: git-email = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: emacs-git = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: git-arch = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: gitk = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: git-gui = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: git-core = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: perl-Git = 1.5.3.8-1.fc8 for package: git
> --> Processing Dependency: git-svn = 1.5.3.8-1.fc8 for package: git

"git" is a dummy/virtual package that you use when you want all the
possible subpackages.  That includes:
- gitk -> needs tk
- some gui tools (git-gui) -> needs tk
- svn converter support (git-svn) -> needs svn
- cvs converter support (git-cvs) -> needs cvs, cvsps
- emacs mode (emacs-git) -> needs emacs
- arch converter support (git-arch) -> needs tla (aka arch)

For normal use, you want git-core and probably gitk.  The others can
be handy at times, especially git-svn.

  OG.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]