[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: rpms/igraph/devel igraph.spec,1.10,1.11



Jesse Keating wrote:

> On Sun, 17 Feb 2008 10:53:02 -0500
> Neal Becker <ndbecker2 gmail com> wrote:
> 
>> I'm confused.
>> Without adding Provides:        %{name}-%{version}, I have:
>> 
>> rpm -q --provides -p
>> ~/RPM/RPMS/x86_64/igraph-devel-0.5-8.fc8.x86_64.rpm igraph-devel =
>> 0.5-8.fc8
>> 
>> igraph-devel and python-igraph have the same version, but different
>> release, so don't I need this provides in igraph-devel and requires in
>> python-igraph, so the requirement is:
>> igraph-devel = 0.5
>> without release number?
> 
> I'm having a real hard time following this.
> 
> Can you start from the beginning, what you think the problem is?
> 

We have a new upstream for igraph, version 0.5.

I'm trying to build igraph-0.5 and python-igraph-0.5.

igraph-0.5-8.fc8.src.rpm builds
igraph-0.5-8.fc8.x86_64.rpm
igraph-devel-0.5-8.fc8.x86_64.rpm

We have python-igraph-0.5-4.fc8.src.rpm.

If I don't put any provides in igraph-devel, it says:
rpm -q --provides -p ~/RPM/RPMS/x86_64/igraph-devel-0.5-8.fc8.x86_64.rpm 
igraph-devel = 0.5-8.fc8

And IIRC, if I don't put any requires in python-igraph, it will say:
igraph-devel = 0.5-4.fc8

Which don't match.  So I thought the correct thing to do was put
provides/requires that strip off the release/dist and just say:
igraph-devel = 0.5

Is this wrong?  What should I do?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]