[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: anjuta for F8

On Feb 17, 2008 12:18 PM, Debarshi Ray <debarshi ray gmail com> wrote:
> For installing gnome-build 0.2.1 from F8 updates, I had to remove
> anjuta 2.2.0

That is because the soname of the libraries provided by gnome-build
has changed. The version of Anjuta that is available in the
repositories is really old and was not built against these new

> In file included from ../libanjuta/anjuta-shell.h:29,
>                  from anjuta.c:22:
> ../libanjuta/anjuta-preferences.h:24:25: error: glade/glade.h: No such file
> or directory
>  In file included from ../libanjuta/anjuta-shell.h:29,
>                  from anjuta.c:22:

That is because of a problem in one of the Anjuta Makefiles.

> /usr/bin/ld:
> /usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../lib64/libbfd.a(format.o):
> relocation R_X86_64_32 against `a local symbol' can not be used when making
> a shared object; recompile with -fPIC
> /usr/lib/gcc/x86_64-redhat-linux/4.1.2/../../../../lib64/libbfd.a:
> could not read symbols: Bad value
> collect2: ld returned 1 exit status

I have also encountered this, but have not fixed it yet. Any
suggestions would be much appreciated.

> This the the .src.rpm I am using, in case someone can take a look at it:
> http://people.atrpms.net/~pcavalcanti/srpms/anjuta-2.2.3-13.fc8.src.rpm

Please try the following:
Spec: http://rishi.fedorapeople.org/anjuta.spec
SRPM: http://rishi.fedorapeople.org/anjuta-2.2.3-1.fc8.src.rpm

It contains a couple of patches, one of which fixes the glade.h
related build failure. I expect them to work on F-8 and hopefully on
F-7 too.

The patches worked perfectly.

I have already built anjuta for F8. 
Thanks a lot.

Paulo Roma Cavalcanti
[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]