[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Rawhide problems: Long boot delay/timeout loading Udev



Ryan B. Lynch wrote:
Thanks for the tip! It was a little hard to figure out from the debug messages (udevdebug throws out a *LOT* of verbiage), but it looks like there was at least one kernel oops in the udev driver.

I haven't had time to get in-depth with it, though. I tried reverting back to a 2.6.23 kernel (I was running the latest 2.6.25 in rawhide), and it seems to work just fine.

I can certainly contribute what I've got to a bug report, though. I'm a little new to rawhide--what's the appropriate next step, for a bug that seems to lie in a packaged kernel?

Well, you could try to get something readable you can share in a bug report, even if its just a picture of your screen at the time the oops flies by. If you can still get passed that point enough to login with udevdebug set and get dmesg saved then try that and you can attach it to a bug report against the kernel.
dmesg > /tmp/dmesg-udev-hang.txt

I've never figured out how to go to the next step of capturing debug messages through a serial com port, would be a neat trick to learn soon.

What kernel version is this? The latest pushed into rawhide is kernel-2.6.25-0.40.rc1.git2.fc9, so is that the one with udev issues for you?

In case you're unaware, you can get other kernel builds out of koji and try them as well; there are two newer kernels built there, but they aren't in the repo yet so their could be a reason for that. Usually doesn't hurt to try them anyway. :)
http://koji.fedoraproject.org/packages/kernel/

--
Andrew Farris <lordmorgul gmail com> www.lordmorgul.net
 gpg 0xC99B1DF3 fingerprint CDEC 6FAD BA27 40DF 707E A2E0 F0F6 E622 C99B 1DF3
No one now has, and no one will ever again get, the big picture. - Daniel Geer
----                                                                       ----


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]